Summary
For some customers with the SaaS (cloud) implementation of FlexNet Manager Suite, FlexNet Beacon installations of versions earlier than 2017 R2 may disable the beacon user interface, due to a failure of the signature check on the downloaded beacon policy.Symptoms
When attempting to open the FlexNet Beacon interface, all pages are hidden, other than the Parent connection page. This page will display the following warning:?The beacon control file (policy) is missing, or does not contain license information. Please restart the beacon interface.?
Note: Although the other user interface pages are suppressed, the inventory beacon continues to operate with the previously available settings. For example, if this inventory beacon was collecting weekly inventory from an Oracle database, or if it was uploading FlexNet inventories collected by installed FlexNet inventory agents, these and similar operations continue as before.
Cause
This issue is only triggered when:- Your current settings do not allow automatic updates of your inventory beacons to the latest release of FlexNet Beacon; and
- The downloaded inventory beacon policy includes one or more targets (for discovery and inventory rules) that identify specific devices.
Resolution
Updating your inventory beacons to version 12.3.0.15241 or later (the current version at time of publishing this article) will resolve this issue:- Log into the web interface as an operator in a role with administrator privileges, and navigate to Discovery & Inventory > Settings.
- Scroll down to the Beacon settings section, and in the Beacon version approved for use drop-down list, select Always use the latest version (currently 12.3.0.15241), or choose the individual release number 12.3.0.15241.
- At the bottom of the page, click Save.
Workaround
As a temporary workaround instead of upgrading inventory beacons, you can disable the policy signature check. However, while this workaround restores the display of pages in FlexNet Beacon, Flexera recommends that you do not disable policy signature, as this increases the exposure to security threats. If you choose to temporarily disable the policy signature check:- Log into the inventory beacon using an account with local administrator privileges.
- Open the registry editor.
- Navigate to HKML > SOFTWARE > WOW6432Node > ManageSoft Corp > ManageSoft > Compliance > CurrentVersion
- Rename the CertificateFile key to CertificateFile1. This name change disabled the signature check. Be sure to revert this name back as soon as possible.
Additional Information
This issue is tracked as FNMS-50446 ?FlexNet Beacon earlier than 2017 R2 fails signature check on cloud policy downloads when specific device(s) are used in target?.Was this helpful?
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Case id: 00001065
Activity: Status change: 2 hours ago