Summary
Discussion and resolutions on run time error 1628.
Symptoms
Error 1628 is displayed by setup.exe in the following format:
"Failed to complete script based install"
or
"Failed to complete installation."
This error is only encountered at run time. This error normally occurs during uninstallation, repair, or when applying a patch.
Cause
There are a number of possible causes for this error. Please see the known causes and resolutions below.
Resolution
A. iDriver.exe (ISSetup.exe in InstallShield 12 and later) is not cleaned up at the end of the installation, and the uninstallation log file becomes corrupted.
- Use the Windows Task Manager to end the
iDriver.exeprocess. If you are not sure how to access the Task Manager, see the Additional Information section. - Delete the
.ilg(uninstallation log) file from the<PROGRAMFILES>\InstallShield Installation Information\{Product Code}directory. If you do not know your project's Product Code, it can be found under the General Information > Product Properties view in the InstallShield Development Environment (IDE). -
Search the project for duplicate features. This can be done via the Setup Design, Features, or Direct Editor views. If any duplicates are found, one of them must be renamed, and the release must be rebuilt. For example, if an InstallScript MSI project has two features with the same name but defined in different cases such as DefaultFeature and defaultfeature.
B. The installation has at least one child feature whose Required Features property is set to either a Parent or GrandParent feature.
By default, parent features and grandparent features are forced to be required if the subfeature is selected, so this does not need not be done explicitly.
- Select the Setup Design view.
- For each subfeature, check its Required Features property and verify that is value is None Selected. Change the value in this field if necessary.
C. A setup was created that requires MSI 2.0, but an MSI version less than 2.0 is installed on the machine.
- Select the Releases view.
- Select the release you are currently building.
- Find the Setup Launcher property on the right side and verify that the value is set to Yes (Include Windows NT & Windows 9x MSI engines). This can also just be set to Windows NT or Windows 9x if you are only distributing to one operating system.
- Find the MSI Engine Version property on the right side and verify that the value is set to 2.0. Change this to 2.0 if it is set to an earlier version.
- Rebuild the release. The MSI 2.0 engine should now be included with your release.
D. The MSI 2.0 engine is being included with the setup but is not being installed.
- Do one of the following:
- If using InstallShield Developer 8 and later: Select Tools > Open Release Folder.
- If using Developer 7.x: Open up Windows Explorer and navigate to the location of your release folder. If you are still not sure where to find the release folder, see the Additional Information section.
- Find the
Setup.iniin the release folder. If thesetup.inifile is not visible see the Additional Information section. - Find the
MsiVersionentry under the[StartUp]section. - Verify that the
MsiVersionentry is set to2.0. If it is set to an earlier version, the MSI 2.0 engine will not be installed. Change the value if needed.
E. A file in the temporary directory is conflicting with the files extracted or used.
Go to the default System Temp directory on the machine and delete all of the files in it by following these steps:
- Launch the file
cmd.exeon Windows NT, Windows 2000, or Windows XP machines or DOS prompt on Windows 9x or Windows Me machines. - Type Set on the command prompt and press Enter. This displays all the environment variables on the machine including
TEMP. TEMPholds the path to the default Temp Directory on the machine. Go to this location through Windows Explorer and delete all the files in this directory.- Relaunch the setup to see if it works.
F. The base installation is not available on the target machine.
Ensure the base setup is installed on the target machine.
G. Error 1628 occurs when running the installation.
This is a general MSI failure error that is caused by the uninstall log being deleted from the system. To get more information, create a log file during run time. If the log file indicates the following:
1: Opening cab file...
1: Failed to open cab, error is 0x80030002
1: InitScript operation failed, error is 0x80030002
1: Shutting down all services
1: Invoking __ISRTRestoreMainLog...
1: Failed to invoke __ISRTRestoreMainLog, error is 0x8002000
Delete the following key:
HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_UninstallInformation{your product guid}
Additional Information
Task Manager
- Access the Task Manager by right-clicking your mouse button on a blank area of the taskbar, and then clicking Task Manager.
- Click the Processes tab.
- Right-click the iDriver.exe process and select End Process.
For more information about the taskbar and how to access the Task Manager, see Windows Help.
Release Location
- Open the Releases view.
- Click the release you are currently trying to build.
- Find the Release Location field on the right side. This is the location of your release. If the Release Location field is using a path variable, the value of this variable can be found in the Path Variables section of the IDE.
Setup.ini
If you cannot find the setup.ini file in your release folder, it is probably because you have built a compressed release in which the setup.ini is embedded into a setup.exe.
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Case id: 00001065
Activity: Status change: 2 hours ago