Summary
Discussion on causes and resolutions for run time error 2762Symptoms
When running an installation, the following error may occur:
Error 2762: Cannot write script record. Transaction not started.
This error is displayed by the Microsoft Windows Installer Service.
Cause
This error is known to occur in the following scenarios:
- This run-time error results on Windows XP machines if the standard actions MsiPublishAssemblies and MsiUnpublishAssemblies are not included in the Execute sequence. This is the case if you migrated your project from a previous version of InstallShield for Windows Installer. These standard actions are New to Windows Installer (MSI) 2.0, which is used by InstallShield Developer 7.01 and above. Previous versions of InstallShield for Windows Installer used earlier versions of the Windows Installer Engine. Unfortunately, these New standard actions are not added during the upgrade process.
- This error is caused by improperly sequencing a deferred custom action. The option to create a custom action as deferred is available in the Additional Options panel of the Custom Action wizard. When using a deferred custom action, it can only be added to the Installation Execute sequence. Additionally, it must be added after the InstallInitialize standard action and before the InstallFinalize standard action.
- This error can occur when a custom action that launches an executable or other file is configured incorrectly. More specifically, this error has been known to occur when the filename is referenced multiple times within the custom action.
- If installing on a Windows XP machine, this error can occur if the MSXML 4 Merge Module is included in the project. This error occurs because these files are already installed by default on the Windows XP operating system, which causes Microsoft's merge module to error out with this message.
Resolution
- To resolve this error, manually add these standard actions to the Execute sequence. To accomplish this, follow these steps:
- Select the Sequences view.
- Expand the Installation folder.
- Expand the Execute node beneath the Installation folder.
- Right-click on the PublishComponents action and choose Insert.
- Select the MsiPublishAssemblies action and choose OK.
- Right-click on the UnpublishComponents action and choose Insert.
- Select the MsiUnpublishAssemblies action and choose OK.
- Rebuild the project.
- Select the Sequences view.
- Make sure that the custom action is sequenced in the Installation Execute sequence, rather than the Installation User Interface sequence. These sequences are available in the Sequences view. Also, make sure that the custom action does not come before the InstallInitialize standard action or after the InstallFinalize standard action. If it does, move it between these standard actions.
Another option would be to make the custom action immediate, rather than deferred. This option can be set in the Custom Action wizard.
Note: If your custom action has been sequenced after InstallFinalize, the installation does not roll back after the Internal Error. This is because the InstallFinalize action commits the changes to the system and deletes all rollback information. To remove the program from the system, uninstall the application.
- Make sure the custom action is configured correctly and only references the name of the file that is to be launched once in the action. This can be done in the Custom Actions view.
- If installing to Windows XP and including the MSXML 4 Merge Module, conditionally install the feature with which this Merge Module is associated. Therefore, it will not install on XP machines but will install on all others. This successfully works around this error and allows the setup to work across all Windows platforms. An example of a condition that would not install on Windows XP is:
VersionNT <> 501
Additional Information
If this error occurs during uninstallation and the product cannot be removed, use Microsoft's Windows Installer CleanUp Utility to remove this application. This utility is also available with the Windows Installer SDK.
Note: This article applies to MSI based installations.
For additional information on the condition specified in Solution D, see to the Windows Installer Help Library topic Operating System Property Values.
For additional information on the differences between immediate and deferred execution of a custom action, see the InstallShield Help Library topic In-Script Execution.
Information on the User Interface, Execute, and other sequences discussed in this article can be found in the InstallShield Help Library topic Defining Sequences.
Related Articles
Windows Installer Error 2762 9Number of Views Windows Installer Error 1310 3Number of Views Windows Installer Error 2732 6Number of Views Windows Installer Error 1706 47Number of Views Windows Installer Error 1907 5Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago