Summary
Error 1920 is a Windows Installer error that occurs only at run time.
Symptoms
Error 1920 is a Windows Installer error that occurs only at run time and is displayed in the following format:
Service '[SERVICE]' failed to start. Verify that you have sufficient privileges to start system services.
[SERVICE] resolves to the name of the service.
Cause
- Cause #1: The service name specified in the project is not the correct service name. This may happen if the Windows Control Panel Services name was used instead of the internal name of the service. The service has a registered, or internal, name and also has a displayed name. These names do not necessarily match. The internal name must be specified in the IDE in order for the service to be controlled.
- Cause #2: A dependent service is not installed or is disabled on the target machine. Some services require other services to be running on the target machine before it will successfully run itself. If these services are not available, the service attempting to be controlled may fail.
- Cause #3: The user does not have rights to run the service. Some services are only available to run under a specific Log On account. The user must be logged on under this account to successfully run the service.
Resolution
Resolution for Cause #1
To resolve this error, follow these steps:
- Download and install the Microsoft ORCA utility from the following article: What ORCA Is And How to Acquire It.
- Open your Express project file (.ism or .ise) in ORCA.
- Select the ServiceInstall table.
- Do one of the following:
- If data exists in this table, note the value in the Name column.
- If data does not exist in this table, select the ServiceControl table and note the value in the Name column of this table.
- Find the internal name by going to a machine that already has the service installed. On that machine, open the registry by typing regedit at the Start | Run command box.
- Once in the registry, navigate to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services. The service's internal name has its own key under the Services key. Because the internal name can be different from the display name, you may not recognize the name displayed. If this is the case, you can click each key under the Services key and check the DisplayName value for the key. The DisplayName value is the name as it appears in the Windows Control Panel. Once you find the correct DisplayName, take note of the key it is found within. - If the internal name matches the name specified determined under Step 4, this is not the cause of the issue. Otherwise, change the name from Step 4 to match the internal name.
- Rebuild the release.
Resolution for Cause #2
To resolve this error, follow these steps:
- If you are not sure which services the service you are trying to control depends upon, check on a machine that the service is already installed. On Windows 2000/XP machines, dependencies can be checked by right-clicking the service and choosing Properties. Under the Dependencies tab, there is a list of the dependent services.
- Verify that all dependent services are installed and running.
Resolution for Cause #3
To resolve this error, follow these steps:
- If you are not sure which account the service logs on as, check on a machine that the service is already installed. On Windows 2000/XP machines, the Log On field can be checked by right-clicking the service and choosing Properties. Under the Log On tab, you can see which account the service logs on as.
- Verify that the user is logged on under the correct account when launching the installation.
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