Summary
When setting an environment variable during the installation, such as with the Environment Variables view, the new or updated variables do not appear during the installation process, for example, when a custom action may try to access the variables.Symptoms
When setting an environment variable during the installation, such as with the Environment Variables view, the new or updated variables do not appear during the installation process, for example, when a custom action may try to access the variables.
Cause
This behavior is due to how environment variables are handled by the Windows operating system and the Microsoft Windows Installer engine. Environment variables set during the installation are not available until the installation exits.
Workaround
Due to this limitation, it is not possible to launch a custom action during the installation and be able to access the new or updated environment variables. A process would need to be launch after the installation process has exited to receive the new variables.
Additional Information
Solution to Environment Variable ProblemsRelated Articles
Exporting environment variables like TNS_ADMIN to the Snow Inventory Oracle Scanner 107Number of Views Creating and Modifying Environment Variables 6Number of Views Environment Variable 15Number of Views Reboot System After Installation completes in Chained MSI - Multi Package Transaction 3Number of Views Launch Application When Installation Completes 3Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago