Summary
This article provides guidance on how to resolve http error 405 when uploading filesSymptoms
- Error 0xE0500195: HTTP error 405
- Error 0xE050044D: Failed to create remote directory /ManageSoftRL
- Error 0xE0690099: Specified remote directory is invalid, or could not be created
- ERROR: Remote directory is invalid
- Uploading finished
Cause
In FNMS 2014 and above we do not use WebDAV, please see the Additional Information for more details.
Resolution
- Open IIS Manager
- Expand the Computer
- Click on the Web Service Extensions folder
- Does WebDAV appear in the list?
- If yes, is the status set to Allowed?
- If yes, access the Properties. What required files are listed and are they set to Allowed?
- Open Control Panel
- Open Add/Remove Programs
- Click Add/Remove Windows Components
- When it opens; highlight Application Server and Click Details
- Highlight Internet Information Services (IIS) and Click Details
- Highlight World Wide Web Service and Click Details
- Tick the box next to WebDAV Publishing and click OK until you return to the main Add / Remove components windows.
- Click Next and complete the Wizard
<httpHandlers>
<!-- To use SYNC Processing - use "ManageSoft.Import.Web.MgsSyncHandler".
To use ASYNC Processing - use "ManageSoft.Import.Web.MgsAsyncHandler".
IMPORTANT!: Whether to use SYNC or ASYNC must be determined individualy in each concrete given environment.
-->
<add verb="PUT" path="*" type="ManageSoft.Import.Web.MgsAsyncHandler, ManageSoft.Import.Web"/>
<!-- Needed to give the MSG http agent side code the value it expects to find before attemtpitng PUT -->
<add verb="OPTIONS" path="*" type="ManageSoft.Import.Web.UniversalHandler, ManageSoft.Import.Web"/>
</httpHandlers>
Workaround
<add key="ConcurrencyMaxLimit-logs" value="2"/>
<add key="ConcurrencyMaxLimit-inventories" value="2"/>
<add key="ConcurrencyMaxLimit-securityanalysis" value="2"/>
<add key="ConcurrencyMaxLimit-systemstatus" value="2"/>
<add key="ConcurrencyMaxLimit-discovery" value="2"/>
(all values were previously 10)
<add key="WorkloadMaxLimit-logs" value="4"/>
<add key="WorkloadMaxLimit-inventories" value="4"/>
<add key="WorkloadMaxLimit-securityanalysis" value="4"/>
<add key="WorkloadMaxLimit-systemstatus" value="4"/>
<add key="WorkloadMaxLimit-discovery" value="4"/>
(all values were previously 15)
Additional Information
In the Web UI versions (FNMS 2014 and higher) we explicitly do not use WebDAV and the installation guides state in the preparation sections that this should be disabled. If you get this error message, it usually means that there is some element of WebDAV still enabled.Some areas to check:
- Default Web Site -> WebDAV authoring rules -> check Actions on the right to see if it says Disable WebDAV, if so, select that option.
- Also under WebDAV authoring rules (including on the ManageSoftDL and ManageSoftRL sites)
- Restart IIS
Related KB Articles
M100962Q211707
Related Articles
How to Resolve FlexNet License Server Manager Error “PKIX Path Building Failed" 42Number of Views How to configure replication to collect a uploaded agent files on the FlexNet Manager Suite inventory server 45Number of Views HTTP Error 500.19 when accessing ManageSoft DL in IIS 35Number of Views New installation of Columbus or Spider LCM produces error: The request failed with HTTP status 405: Method not allowed 16Number of Views SAPReader process may fail with error when uploading very large SAP data set: "System.IO.IOException: Stream was too long." 8Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago