This article provides steps to resolve the error:
Failed to launch virtual machine. Azure error code: RequestDisallowedByPolicy
which occurs when deploying or starting a virtual machine. This policy error prevents the instance from launching. In production, there will be more information included with the error log, including the name of the policy.
- Review the error message. It includes details of the policy assignment and policy definition causing the restriction, and locate the policy name.
- Check the implemented policy in your Azure environment that is blocking the deployment. The error typically means a policy is restricting VM types or sizes.
- Identify what in the policy is disallowing the resource and adjust the configuration to comply with allowed settings or update the policy as needed through your organization's Azure governance process.
- For more details and troubleshooting steps, refer to: Azure troubleshooting guide: RequestDisallowedByPolicy.
Was this helpful?
Related Articles
Delete an Azure stateful node and migrate its virtual machine to Azure 46Number of Views Fix the “RequestDisallowedByPolicy” message when launching a virtual machine 6Number of Views Azure error: Invalid client secret provided 33Number of Views Max Spot Instance Count Exceeded error when launching AWS Spot Instances 23Number of Views Azure VM import fails with error: Parameter 'id' is required and cannot be null 8Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Revenera Assistant
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago